CloneDVD mobile hangs when creating M4V/ MP4s

Discussion in 'CloneDVD mobile' started by Taigon, Apr 26, 2012.

  1. Taigon

    Taigon New Member

    For the last year I have not been able to get CloneDVD to complete an MP4 conversion of anykind. Prior to this time, it worked beautifully. I recently reinstalled everything from the ground up on my desktop in hopes of fixing this problem but it still did not solve it.

    I am running Windows 7 64 bit Home Premium.
    I have the latest versions of AnyDVD, CloneDVD, and CloneDVDmobile installed. The other two programs work fine, but mobile doesn't.

    I also have the following programs installed, in case anyone is aware of any conflicts with them:
    Bitdefender Total Security
    Microsoft Office 2007
    Quickbooks Pro 2010

    I have tried all of the recommendations from the forums and Slysoft support that I have been able to get. Including: run as administrator, windows xp2 and 3 compatibility mode, uninstall and reinstall, scream and yell, jump up and down, curse, etc.

    Any insights that would help me are appreciated.
  2. Adbear

    Adbear Well-Known Member

    Have you tried running things like memtest etc? It's possible you have a faulty component that only shows up when your system is being stressed
  3. Taigon

    Taigon New Member

    No faults with memtest.
  4. Taigon

    Taigon New Member

    I looked at ffmpeg.exe *32

    This process just simply quits producing anything. The process is still running but not using any CPU. It just drops to zero.

    Further, I noticed that even though CloneDVDmobile is running in compatibility mode that ffmpeg.exe is not.

    Has anyone tried forcing ffmpeg.exe to run in the same compatibility mode as CloneDVDmobile?
  5. Adbear

    Adbear Well-Known Member

    How about disabling the antivirus or adding the programs to the 'excludes' list. Also have you tried disabling UAC?
  6. Taigon

    Taigon New Member

    I appear to have this solved thanks to Adbear's recommendations. The combination of the following steps have allowed me to convert my first MP4 file in over a year.

    1. Set compatability to Windows XP service pack 2 for the following programs:
    CloneDVD mobile.exe
    2. Allowed "exlusion" of Bitdefender Total Security 2012 for the following programs:
    CloneDVD mobile.exe

    This has allowed the conversion process to continue without hanging. I never did receive any forms of notifications from either Windows or Bitdefender that they were preventing something. It appears to me that interaction between mencoder and ffmpeg was being prevented. I don't know the programming details though. Nonetheless, the above steps solved the problem.

    Frank, I don't see the need to post a log file. I will however, if you would still like it.
    Last edited by a moderator: Jan 4, 2013
  7. Frank

    Frank SlySoft Support Team

    Interesting twist

    This is good news and not the first time that poorly written anti virus products invade innocent processes. No need to a log now. It would have shown me the details of the processes and what was going on there. I suspect the white-listing of CDm's engine components fixed this. The compatibility thing usually comes into play if CDm closes immediately after selecting the VIDEO_TS folder with or without an App-Crash message from Windows but it's OK to have set that mode.

    I'm sorry I was asleep at the wheel on this one when you opened your tickets some time ago.
    Last edited: Apr 28, 2012
  8. gstory

    gstory New Member

    Not the only one

    Don't worry, your not the only one having issues. My problem started when I tried to convert to the Apple TV format. The program would just fail, but ipad format would work. Sometimes I would get an error log message and other times the program would just stop processing the files. The processes were still running, but nothing was happening. Support had me try a few things, but in the end they could not fix it. Said I was the only one reporting a problem.

    Until I found this posting I was about to uninstall the darn program and look for something else to use.

    Anyways, I followed the posting talking about running the program in Windows XP compatibility mode. I also added the exe files to my virus protection for good measure. That fixed the problem with the program crashing or freezing up. However, now the sound is not synced to the lips!!

    My advice to anyone with the program crashing, freezing, or just not recording. Browse to your install folder (C:\Program Files (x86)\SlySoft\CloneDVDmobile). Right click the CloneDVDmobile.exe file and set it to use Windows XP mode. Do the same to the .exe files in the "apps" folder. See how that works for you.

    Edit: Looks like the sound sync problem is very well known. Support says this problem will not get fixed until later this year. While we wait, they ask that we use an older version of the program.
    Last edited by a moderator: Jan 4, 2013
  9. Frank

    Frank SlySoft Support Team


    Always ready for a surprise in this business I read your post with great interest.
    That is indeed an unusual thing to do with the XP thing. And the anit-virus influence is also now known for sure to cause problems. Why this interference is not immediately occurring is not known and processes stopping in the middle are difficult to analyze.
    And why this affected only one specific Apple profile is another mystery.

    I am glad to learn you found a way to get around this now and we appreciate your contribution.

    As for the sync thing we know about this since we modified the engine some time ago and the 1802 version will allow you to get around that.

    We will address these issues as soon as we can and we apologize for the inconvenience.

    Note: Other anti-virus products like Symantec and AVG are also known to interfere in this process so be aware that not only BitDefender affects this process.
    Last edited: Jan 4, 2013