Does this sound like a bad disc/drive?

Discussion in 'AnyDVD HD (Blu-ray)' started by ddjmagic, May 21, 2012.

  1. ddjmagic

    ddjmagic Well-Known Member

    I am trying to playback Avatar ECE Disc (Region B), all the discs seem to show fine in windows explorer, and I can playback with Arcsoft, but when I open AnyDVD HD (latest) it just keeps scanning the disc and nothing happens, Disc 3 is fine but 1 and 2 won't load.
    I have exchanged the Blu-ray and exactly the same thing happens with Disc 1 & 2, 3 is fine again. All other movies I own work fine in the drive.
    Did I just get unlucky with a few bad discs? Should I try exchanging again?
    Or could my BD drive be going bad?
     
  2. whatever_gong82

    whatever_gong82 Well-Known Member

    Please check out the link here on Blu ray disc read errors, and follow all the info therein.

    Hopefully, you can get it (the movie) to work.
     
  3. FurryGuy

    FurryGuy Well-Known Member

    Discs are mastered and pressed in batches, so it is not uncommon to get defective discs, especially from the same source.

    Avatar was successfully handled by AnyDVD quite a while ago, so any problems could result from defective discs.

    A last resort before you go on an exchange binge is to clean the BDs your are having problems with since there can be a thin film from the manufacturing process still on the physical disc that degrades a bib-for-bit read.
     
  4. ddjmagic

    ddjmagic Well-Known Member

    I have followed the guide in the sticky and made a sucessful protected image of the troublesome discs with Imgburn, I have mounted the image (Virtual Clonedrive) and it plays fine in Windows/Arcsoft but again when I use AnyDVD HD with the mounted image (image on local drive) it just hangs and status says scanning disc.

    I guess this would eliminate the BD drive since it made a successful rip with Imgburn, must have gotten a bad batch? What do you guys think?
     
  5. Adbear

    Adbear Well-Known Member

    How did you play back the protected image if you didn't have AnyDVD HD running in the background?
     
  6. ddjmagic

    ddjmagic Well-Known Member

    Just checked and turns I was looking at the wrong drive in AnyDVD HD status window :eek:, the mounted image does work in AnyDVD HD, but I had left the orginal disc in the BD drive, thats what AnyDVD HD was scanning, it had already read and stripped protection of the mounted image, hence the playback :)
    So would you agree that the drive is OK and it definitely is the disc? I don't have another drive to test with.