Once Upon time in China Series Blu-ray

Discussion in 'AnyDVD HD (Blu-ray)' started by jayaramansriram, Mar 23, 2012.

  1. Hi,

    Yesterday ( 22-Mar-2012 ) Tried playing all the three movies blu-ray discs in my blu-ray drive i.e Sony Optiarc BD-5300S drive. initially 1st movie disc played normally, second and third disc didn't play.

    link to the movie blu-ray - Region A - http://www.yesasia.com/global/once-...ng-kong-version/1022116605-0-0-0-en/info.html

    Then I had updated the firmware version from 1.04 to 1.06 through the sony optiarc website - http://www.sony-optiarc.eu/supportservice/downloads/bd5300s.html.

    today ( 23-Mar-2012 ) I had tried again playing second and third however second disc played and not the third one.

    Note - Third disc however played in my blu-ray player.

    Could somebody help me out with this.

    Regards,
    Sriram
    India.
     
  2. Adbear

    Adbear Well-Known Member

    In what way 'didn't play'? If you mean that the discs just aren't seen by the drive then there's nothing you can do other than either try replacing the drive or the discs.

    See this sticky
    http://forum.slysoft.com/showthread.php?t=30640
    it explains why
     
  3. Dear Adbear,

    the blu-ray drive doesnt recognize the third disc however same problem I had yesterday with second disc but it played today.

    should I try cleaning the drive or kindly suggest me any better alternative.

    Thanks

    Regards,
    Sriram
    India.
     
  4. Adbear

    Adbear Well-Known Member

    Try cleaning the discs, if that doesn't work then you have no choice but to either try another drive or try another set of discs
     
  5. tried cleaning the discs using cotton... it worked out and intially i was using trial version of anydvdHD 7.0.0.0 but now bought the lifetime license and I am able to play the third disc now.

    Thanks for the help.