PowerDVD 12 reports "unsupported format" using VCD with BD ISO

Discussion in 'Virtual CloneDrive' started by pymercier, Feb 9, 2012.

  1. pymercier

    pymercier Member

    With Powerdvd 11 no problem is OK

    Do you have any troubleshooting suggestions?

    I use windows XPx64 and 7x64 I the same problem.
  2. DrinkLyeAndDie

    DrinkLyeAndDie Moderator (en)

    Just played back a mounted full-disc image of a Blu-Ray. I used the latest VCD release and PowerDVD Ultra 12. No issues with playback of the mounted ISO.

    Running Windows 7 Ultimate x64 fully updated.
  3. pymercier

    pymercier Member

    OK thank you very much ,
    I have not problem with original blu-ray-disc
    But I use full copy ISO Blu-ray. I use Imgburn (for copy with command line) with anydvd HD,
    And I try with anydvd hd ripper, I same problem.
    I search in tis forum and I exactly the same problem in this post
    But my problem is with Powerdvd 12.
  4. James

    James SlySoft Development Team Staff Member

    PowerDVD the standalone player, or the media center plugin? (These are two different programs).

    EDIT: AFAIK Cyberlink calls it "Cinema mode".
    Last edited: Feb 10, 2012
  5. pymercier

    pymercier Member

    I use only PowerDVD12 standalone player
  6. dSkuld

    dSkuld New Member

    I have the same issue:

    Ripped Blu-ray to ISO using AnyDVDHD, with "Remove Prohibited user operations" and "Remove Blu-ray Region Code" selected.

    Mount the ISO using VirtualCloneDrive

    I attempt to play the mounted ISO using PowerDVD 12.0.1312.54 Ultra.

    PowereDVD comes up with a dialog saying "CyberLink PowerDVD cannot access the storage device. Select another device when playback stops." and then another message "The integrity of CyberLink PowerDVD is at risk. Check your anti-virus software for malicious activities or try reinstalling CyberLink PowerDVD"

    PowerDVD 11.0.2408.53 Ultra played the same mounted ISO fine.

    (This is all on the same machine, running Window 7 Ultimate 64bit)
    Last edited: Feb 18, 2012
  7. Adbear

    Adbear Well-Known Member

    Works fine here, sounds like you've either got corrupted iso or more likely a corrupted install of PDVD 12
  8. dSkuld

    dSkuld New Member

    @Adbear, this is weird. I enable AnyDVDHD for the VCD drive once, and now it seems to work all the time.
  9. Jeff R 1

    Jeff R 1 Well-Known Member

    Cyber DVD12 Will Not Play ISO's

    There is a problem with this over at Cyberlink's forums as well. Follow these steps.
    Uninstall all Cyberlink players including DVD12. Uninstall all Microsoft Redistributable packages found in "Programs and Features"

    Install CCleaner and run it's registry cleaner as many times as necessary until it finds nothing and restart.


    Save Power DVD12 to the desk top and install it from there, not from a temporary folder. It will install 3 Microsoft Redistributable packages.
    After it's done restart your machine and that should look after the problems with ISO files.

    Also, remember to use the BETA version of Any HD DVD. version

    Last edited: Feb 18, 2012
  10. carlolsen

    carlolsen New Member


    I think I have a simpler solution for PDVD12 users...

    Install PowerDVD 12 version (or patch) 1618 from around Feb 2012. Your current version will be uninstalled..do not save personal settings when prompted.
    Open PDVD, activate and then click on the update arrow..top left corner.
    Install the latest update.
    Should now be OK.

    I believe a Microsoft platform update a week or so ago "broke" PowerDVD12.
    I found that I had to go right back to early 2012..the August version didn't fix the problem.

    I experienced the same problem with PDVD11 too so maybe reverting to an early 2012 version will fix that too.

    Let me know if it works. If it does I'll post it on the Cyberlink forum.

    Good luck,