Unable to Create Readable ISO from Blu-Ray

Discussion in 'Third Party Products' started by lwoodring, May 1, 2012.

  1. lwoodring

    lwoodring New Member

    When I use ANYDVD HD and try to rip a purchased Blu-Ray DVD (Watchmen) to an ISO image - the software will rip it, but the resulting ISO image can't be seen by any other software. I am using Aimersoft Blu-Ray DVD Ripper, and also Aimersoft Video Converter Pro - neither can see the ISO image.

    Using ANYDVD HD - how do I rip a Blu-Ray DVD to something that I can then convert to something that I can pull into iTunes and see on an iPad?

    Thanks

    Lee
     
  2. Frank

    Frank SlySoft Support Team

    Yes, you asked this already

    I just answered this in Support. And have you asked their support about this? They DO have one, yes?
    And what exactly is the error this program is showing you?
    AnyDVDHD creates an international-standard image that is recognized very well by other programs including tools for burning blurays.

    You can as well "rip video...." on the right mouse click menu on the AnyDVD tray icon and then select what you want from the hard drive for your conversion to mobile devices, assuming you have the correct options in that program you use.

    Moving this thread.
     
    Last edited: May 1, 2012
  3. Adbear

    Adbear Well-Known Member

    Well unless they've changed in the past couple of years the Aimersoft software was always complete rubbish and never worked as advertised.

    Having downloaded the Blu-ray ripper software to test out it only has DVD ISO as an option not Blu-ray ISO, so I can only assume that it doesn't recognize the Blu-ray ISO structure as I know the ISO's I tried work fine when mounted and played in pretty much any other software.

    It only seems to work with Blu-rays if you use it from a mounted ISO or from a disc, I also find it strange that for a converting software it keeps trying to gain access to the internet when there's no need for it to do that
     
    Last edited: May 1, 2012
  4. bellbern

    bellbern Member

    Inception (No video Not in english)

    I used anydvd hd to rip to harddrive and the results were movie in a foreign language. The setting is set to automatic language. I also do no have video. After ripping I use WMP to play and no video and not in english. Can anyone help this beginner.
     
    Last edited: May 12, 2012
  5. Adbear

    Adbear Well-Known Member

    You need to use playback software that can handle the HD audio and the video codecs used on Blu-ray, WMP doen't like either. For best results use a proper commercial Blu-ray playback software like TotalMedia Theatre and play the disc back as a fulll structure, or if you must play back the file then use something like MPC-HC