VCD in Windows 8.1

Discussion in 'Virtual CloneDrive' started by Bayilo Kanto, Jun 27, 2013.

  1. Bayilo Kanto

    Bayilo Kanto Member

    VCD is running unable to mount any virtual drive in the newly release of Windows 8.1. Its setting window shows an accurate configuration with a given number of virtual drives (7 for my setup) but after I click "ok", no virtual drive is mounted at all.
     
  2. James

    James SlySoft Development Team Staff Member

    which version?
     
  3. solaire

    solaire New Member

    I've got the same problem with the version 5.4.6.0
    It says it can't open VCD.
    I can open the programm itself but I can't mount anything.
    Tried another programm (a windows tool) and it didnt work either.
     
  4. solaire

    solaire New Member

    It does work with the new beta somehow. maybe because it reinstalled the driver..:)
     
  5. Bayilo Kanto

    Bayilo Kanto Member

    Both 5.4.6.1 beta and 5.4.6.0
     
  6. James

    James SlySoft Development Team Staff Member

    I can confirm this problem with Windows 8.1 preview.
    VCD will only work once after it is installed.
    If the PC is restarted, VCD will fail to work (Code 18 in device manager).
     
  7. gojuster

    gojuster New Member

    I can confirm that as well. ver 5.4.6.1 does not work. After you install it it works right away.. but if you reboot.. it does not. Let us know if you need us to get you any info.

    -- Goju
     
  8. Ch3vr0n

    Ch3vr0n Translator nl

    That will probably be a job for Elaborate bytes (Elby). They're the dev's for the software. Slysoft only offers a download to it.
     
  9. James

    James SlySoft Development Team Staff Member

    Please try VCD 5.4.6.2
     
  10. Loonier

    Loonier Well-Known Member

    From time to time I have a feeling there might be a sly helping hand :rolleyes:
     
    Last edited: Jul 2, 2013
  11. Bayilo Kanto

    Bayilo Kanto Member

    It is working fine now

    It is working fine now. Thank you for your quick response. Please check another problem that I wrote on the AnyDVDHD section of SlySoft Forum which is related to blurays playback due to HDCP.
     
  12. techguy

    techguy Member

    I can also confirm that the beta version 5462 now works in windows 8.1 preview. James, thanks for that's quick turnaround on that.

    In a related note the built-in virtual DVD drive feature in Windows 8.1 also works but not as convenient to use as it's only created dynamically when an .iso file is opened and assumes the first available unused letter. It's also gone after a re-boot so in the end the Elaborate bytes version is much better to use.
     
  13. Adbear

    Adbear Well-Known Member

    Does it actually work with Blu-rays (if you mount a Blu-ray ISO is it playable in TMT or PDVD?)
     
  14. James

    James SlySoft Development Team Staff Member

    The Windows version? No.
     
  15. Adbear

    Adbear Well-Known Member

    I wasn't sure if they'd fixed it in 8.1
     
  16. techguy

    techguy Member

    Actually it appears that it is fixed in windows 8.1 for the windows virtual DVD drive version. I didn't work in Windows 8 PRO when I tried it but I just tried it yesterday with 8.1 and POWERDVD13 trial and I was surprised to see that it did work for me.
     
  17. James

    James SlySoft Development Team Staff Member

    It isn't. And it probably never will be (not in Microsoft's interest ... yet).

    Did a little testing with Windows 8.1 image mounting.

    AnyDVD sparse files: Fail to mount at all. Pathetic, as I don't know how you can make this *not* to work.

    WinDVD 11, PowerDVD 10 (my personal favorite), PowerDVD 12, TMT5: Won't play a BD image. All abort with an error like "invalid disc" or similar.

    Virtual CloneDrive:
    All players mentioned above play without any problem. Sparse files work (of course).

    My conclusion: Forget the Windows thing. Use VCD. It works. Rock solid.
     
  18. techguy

    techguy Member

    James,

    Sorry to have to disagree with you but the Windows version of virtual drive is working in 8.1, combined with POWERDVD13 (the trial version as I did not purchase it). I also did not try prior versions of POWERDVD so can't comment there. The test I performed was playing one of several Blu-ray discs previously ripped thru ANYDVD HD and this worked in 8.1 with windows drive. It did not work in windows 8 before it.

    Having said this as I noted in prior comment, I'm sticking with VCD now that it is working with the latest beta as well as it always was much better given that it's permanent and dependable.

    The windows version of this software is pretty dumb. It dynamically creates a new drive every time you open an .ISO file so after you open a few of them you end up with a bunch of drive letters used up. YOu have to re-boot to get rid of them. How dumb is that.
     
  19. James

    James SlySoft Development Team Staff Member

    I haven't tried PowerDVD 13 (as actually nothing else seemed to work, I din't feel it necessary), so I don't know, but are you sure you really tried a BD image? Not a DVD image (which I would expect to work... at least a little bit) by mistake?

    I would be very surprised, if Cyberlink changed their drive reading code from 12->13.
     
  20. techguy

    techguy Member

    James,

    Sorry for late reply here but yes I can verify that it was a Blu-ray disc previously processed thru ANYDVD HD (I've been using your product for many years now) and using the Windows 8.1 Preview virtual drive combined with Powerdvd13. I had not installed the elaborate bytes version on this computer and I also don't have a physical drive on this testing computer I use so it had to pass thru the Microsoft virtual drive for it to work. I had to manually mount the disc so I could actually see it creating the virutal drive on the fly and working.
     
Loading...