Virtual CloneDrive and Windows 7

Discussion in 'Virtual CloneDrive' started by dabl, Jan 9, 2009.

  1. dabl

    dabl Active Member

    Do any versions (beta or otherwise) run under Windows 7?

    If not are there any plans to support Windows 7?
  2. James

    James SlySoft Development Team Staff Member

    Don't know. But I (almost) see no reason why it shouldn't. You can try it yourself.

  3. skypx

    skypx Well-Known Member

    I tried it, it seemed to install fine, but I could not get AnyDVD HD to work (64bit version of win 7) so I gave up and uninstalled both.
  4. dabl

    dabl Active Member

    Thanks James.

    I'd seen the below referenced post and thought I'd check here.

    Reading it again it sounds like the user possibly has an unrelated problem.
    Lost Live TV after installing VirtualCloneDrive. I had go back to a restore point.

    Has anyone got VirtualCloneDrive installed on thier systems?
  5. dabl

    dabl Active Member

    For what it's worth I saw the below referenced comment from Paul Thurrott but he doesn't mention whether this applies to the 32 or 64 bit version of Windows 7 nor does he mention the HD version of AnyDVD
    Slysoft applications. I use and recommend SlySoft AnyDVD, CloneDVD, and CloneDVD Mobile, and these applications all work just fine in Windows 7.
  6. friend

    friend Well-Known Member

    Anydvd HD and VCD work fine on win 7000 32 bit.
  7. erk48188

    erk48188 New Member

    i installed vcd on my eee 1000h. i *think* i needed to run it in vista compatibility - i don't remember. but when i tried to run it did not seem to set up a virtual drive.

    i putzed with it some more, then decided to uninstall it. the uninstall seemed to hang. i left it for about 30 minutes and finally killed the un-install.

    as expected, vcd was still in my add/remove programs, and when i tried to uninstall it again it experienced problems.

    i'm going to try it again on my dell 1420 here shortly...but i really hope to use it on my netbook.
  8. ANVIL

    ANVIL New Member

    VCD issues with Win7

    All of my SlySoft products work fine under Win7 except for the CloneDrive. I've tested with both Enterprise and Ultimate x64 editions with no luck on either one. This issue, for me, is isolated just to this product and is not due to other apps (several tests as the first app installed after fresh install).

    After isntalling VCD, I'm unable to restart or shut down, the system hangs on the shuting down screen. After a hard shutdown and restart, the system restarts as what'd appear to be as expected but some services fail to respond and I'm still unable to restart. The failed services also prevent uninstallation as well as restoring. Restore had to be completed from the installation DVD.

    The same has been tested with the same results using the Beta version posted by James.
  9. CRC

    CRC Member

    Confirmed issues on W7...

    Hi guys,

    I can confirm a bunch of issues running under Windows 7.

    It seems as though it's a memory leak - as RAM will continue to be eaten up (by approx the same amount that's read from the ISO/image) until the system exhausts all available memory. At this point, the only way to recover is to hard reset the computer.

    I've attached a quick screenshot of a basic installer running from an ISO. When installing from the optical media, memory usage never goes over 900Mb. When installing from the ISO mounted with CloneDrive, the screenshot is what happens.

    EDIT: Interestingly enough, when I reinstall VCD, the memory is released after I install the new driver. This leads me to believe that the issue lies in the virtual disc driver. Added screenshot of memory usage when re-installing VCD.

    EDIT2: This still happens with v5.4.1.4 beta.

    Attached Files:

    Last edited: Jan 11, 2009
  10. James

    James SlySoft Development Team Staff Member

    You can try "buffered I/O" in VCDPrefs. Change this setting before mounting an image.
  11. erk48188

    erk48188 New Member

    just wanted to add that i tried using buffered i/o and still experienced the same problem.
  12. James

    James SlySoft Development Team Staff Member

    Well, it looks like VCD under Windows 7 (64bit) is a not working.
  13. talon95

    talon95 Well-Known Member

    It isn't working properly for me in Win7 7000 32bit either. I got in installed (got the unknown driver warning from Win7), but it appeared to work.

    Once installed though, it struggles to mount/unmount DVD images. It works part of the time. Adding more drives only works by adding and then restarting. Win7 is also now hanging up on a restart/shutdown as previously noted. I'm pretty sure this started after installing VCD.
  14. CRC

    CRC Member

    Hi James,

    My setup is running the 32bit version of Windows 7. I have also confirmed the same behaviour with and without the buffered I/O option being enabled.
  15. James

    James SlySoft Development Team Staff Member

    Well, then it isn't working on Windows 7 32bit... :(
  16. CRC

    CRC Member

    Seems to be the case... If you would like to me test any code etc, please email me and I can reply with my results of the testing.
  17. James

    James SlySoft Development Team Staff Member

    I'll do that.
  18. SvenC

    SvenC Member

    explorer.exe hangs after hibernate/resume


    I have no problems installing and using VCD 5.4 on Win7 32-bit and Win2008R2 x64. (on x64 you may have to use F8 when booting to start windows without driver signing requirements - that cannot be turned off since Vista SP1 x64 / Win 2008 x64).

    My problem: after resuming from hibernate I experience hang ups of explorer.exe and of all apps using the common file dialogs. When I start browsing in the file system the corresponding app (explorer.exe, notepad.exe... stop responding)

    Unfortunately explorer.exe cannot be killed, even when elevated as admin (tried task manager, processexplorer ans pskill) I have to power off and restart the system to get control again.

    Without VCD i did not see this behaviour.

    Just upgraded to beta and see what happens.

  19. James

    James SlySoft Development Team Staff Member

    Is the memory freed, when the image is unmounted?
  20. CRC

    CRC Member

    Hi James,

    The memory remains taken when the image is unmounted. The only ways you can free the memory is:
    1) Reboot the PC, or:
    2) Reinstall VCD - causing the driver to be unloaded and loaded again.

    #2 is what I did for the second screenshot I attached to my original report.