Which program fails? (PoweDVD, AnyDVD, W7?)

Discussion in 'AnyDVD HD (Blu-ray)' started by nacio, Sep 18, 2010.

  1. nacio

    nacio New Member

    Hello everybody.
    Till some time ago, I was happily watching BDs with AnyDVD installed and using Cyberlink PowerDVD 9. I made ISOs of my BDs on my drive and watched them through MyMovies in Windows Media Center. 8)
    I admit I stopped for a while and in the meantime upgraded to PowerDVD 10 and latest version of AnyDVD (now
    Yesterday I tried to watch some BDs from ISO files and disk, and PowerDVD did not show anything except this message "Unsupported disk format in drive E" (where E is my BD rom drive)... :confused:
    I try after closing AnyDVD, same message...
    I run Cyberlink BD advisor, and everything ok with my PC, I should be able to playback BD (like I was doing before)... :bang:
    OK... Maybe it's PowerDVD... so I download and install Corel WinDVD 2010.
    Here I get something changing: when AnyDVD is active, still I can't see anything and I get a message similar to that of PowerDVD, but when I close AnyDVD... I can finally playback ALL my BDs.
    I have no idea what's going on! Not an hardware problem I guess...
    Could anybody help? :bowdown:
  2. Ch3vr0n

    Ch3vr0n Translator nl

    We can't help without the logfile that is requested. Read the stickies.
  3. nacio

    nacio New Member

    I read the stickies... just I thought it was not a problem related to just one BD... All my disks just stopped working when before they worked.
    Anyway here you see a logfile with one of the BDs...

    Attached Files:

  4. mike_r

    mike_r Moderator (de)

    Probably not related, but worth a try:


    Summary for drive E: (AnyDVD
    MATSHITA BD-MLT UJ-220S 1.04 08072300
    Drive (Hardware) Region: 2
    Media is a Blu-Ray disc.
    Total size: 24438784 sectors (47732 MBytes)
    Video Blu-ray label: DAYAFTERTOMORROW_F1
    Media is AACS protected!
    Media is BD+ protected!
    AACS MKB version 4
    Using BDPHash.bin 10-09-17
    Removed AACS copy protection!
    Removed BD+ copy protection!
    Note: automatic detection of region code not possible with this disc.
    Blu-ray disc Region set to B!
    Possible Blu-ray Java region lock removed!
    Blu-ray Java signatures fixed!
    BD+ Firmware warning removed!
    The version of AnyDVD you are using ( ) is up to date.
    MATSHITA BD-MLT UJ-220S 1.04 08072300
    Please ensure you are using the latest firmware for your optical drive. See here.

    Rip speeds on DVD and Blu-Ray might be improved by MediaCodeSpeedEdit. Please see RIPLOCK.
    If installed (often from Duplex Secure, Daemon Tools or Alcohol 120% ), uninstall SPTD, which is the culprit for slow rips.
    See here and here.

    Matshita (Panasonic OEM) drives also have a reputation of being cheap junk (which is probably why some laptop companies love these drives)
    They die easily, and also suffer from region coding issues. Click this. They should really be avoided.


    Problematic Filter Afc Possibly Arcsoft Photo impressions installed that filter:
    Afc (system32\drivers\Afc.sys), Version: (
    Company: Arcsoft, Inc.
    Product: Arcsoft(R) ASPI Shell
    Copyright: (C) Arcsoft, Inc. 1999-2005. All rights reserved.
    Description: Arcsoft(R) ASPI Shell
    FileVersion: 1, 0, 0, 2
    ProductVersion: 1, 0, 0, 2
    Refer here for an list of known problematic filters. Further filter information here

    Remove the filter(s):

    1. Create a backup of your registry. Refer here for how to do so.
    2. Download ImgBurn (freeware).
    3. Start ImgBurn and go to Tools > Filter Driver Load Order...
    4. Select "Afc". Click Remove Selected Filter. Click OK.
    5. Reboot.

    Whatever programs installed the filter may no longer work properly.
    Reinstall the piece of software that originally installed the filter to get things working again if necessary.
    It is not recommended that you do so, however, because the problem will likely happen again at a later time
  5. Adbear

    Adbear Well-Known Member

    Wouldn't be surprised if it was the drive, it's a Matshita
  6. Ch3vr0n

    Ch3vr0n Translator nl

    nice spotting there. Matshita drives are idd prone to errors. Especially if the discs region doesnt match the one the drive has
  7. nacio

    nacio New Member

    Thank you all and sorry for my ignorance...
    Could be that the drive is the problem, but... why of these 4 playback combinations with a faulty drive (Matshita), one works?

    1) AnyDVD + PowerdDVD10
    2) no AnyDVD + PowerdDVD10
    3) AnyDVD + WinDVD 2010
    4) no AnyDVD + WinDVD 2010 => THIS WORKS!

    If it was the drive, I would expect none would work.
    And, again, why was all working fine in past?
    As I say, I am not an expert, just use logic.
    Thanks again!
  8. nacio

    nacio New Member

    Yes!!! I was the stupid!!! :clap:

    But anyhow not the only stupid around... as I can understand from Cyberlink site: in fact there are 3 different versions of PowerDVD 10, and only one plays BDs...the "Ultra" one.

    Their site is not clear about that, and apparently many users bought different ones (I had the "Deluxe").

    I am really sorry I made you lost your time on my problem! :eek: